LCDInfo.com

http://www.lcdinfo.com
It is currently Mon Aug 20, 2018 2:40

All times are UTC + 2 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu Oct 07, 2004 14:46 
Offline

Joined: Tue Oct 05, 2004 8:58
Posts: 9
Location: [Ruoho]Lahti
hi,

i've been playing with LCDInfo for a short while and come across something wierd. any time i try to put anything in the lower two lines of my 20x4, i get nothing. nada.
I know the screen works as until about an hour ago it was happily delivering winamp track info.... hmm.... and the top two lines work perfectly.

setup:
8 bit data; HD 44870. LPT1, WinXP SP2, Thinkpad R40. LCDInfo 0.6 Build 18.

have i missed something?

Bret


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 07, 2004 15:12 
Offline

Joined: Tue Oct 05, 2004 8:58
Posts: 9
Location: [Ruoho]Lahti
something else: ä and Ä and Ö and ö don't get displayed properly. this is a screen shot: it should read - "Älkää"
Image

Bret[/img]


Top
 Profile  
 
 Post subject:
PostPosted: Sat Oct 09, 2004 11:13 
Offline

Joined: Sun May 05, 2002 22:05
Posts: 2063
Location: Lappeenranta, Finland
I haven't tested the HD44780 driver that much as it's not written by me but I recently got a 4x40 HD44780 display and when testing with that one it worked fine for me. What happens if you try with the 4x40 setting ?

The reason that letters like ä, ö, Ä, Ö don't display correctly is that the the mapping in the HD44780 chip doesn't match the ASCII table. Workaround for this could be made to the driver. If someone wants to have a try in fixing it I put the source here. It has been published in the forum before but that is the latest version just to be sure.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 15, 2004 10:28 
Offline

Joined: Tue Dec 02, 2003 12:03
Posts: 107
Location: South Africa
I am now busy updating this driver, I will try to fix any errors and do a proper doc about it...

If the last 2 lines don't work, then your e2 line is either not connected or configured to be the wrong pin.

E2 is the chip select for the second hd44780 chip on the 4 line lcds...

_________________
Rudi Grobler


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 15, 2004 14:20 
Offline

Joined: Tue Dec 02, 2003 12:03
Posts: 107
Location: South Africa
The problem is now fixed...

_________________
Rudi Grobler


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 15, 2004 14:21 
Offline

Joined: Tue Dec 02, 2003 12:03
Posts: 107
Location: South Africa
Sorry, the driver can be found here:

http://www.cme.co.za/rudi

_________________
Rudi Grobler


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 15, 2004 15:49 
Offline

Joined: Tue Dec 02, 2003 12:03
Posts: 107
Location: South Africa
Here is a description of the changes made:

http://www.cme.co.za/rudi/pivot/entry.php?id=6

New version is now available...

_________________
Rudi Grobler


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group