LCDInfo.com

http://www.lcdinfo.com
It is currently Mon Oct 22, 2018 10:13

All times are UTC + 2 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: SSD1289 chipset problems
PostPosted: Sat Sep 19, 2009 3:12 
Offline

Joined: Sat Sep 19, 2009 2:58
Posts: 1
I got a cheap 320x240 RGB TFT with the SSD1289 chipset on ebay and I'm having some problems. The Green isn't working as I expect.

If I run the display in 64k colour mode, I can get a smooth Red and Blue gradient. Green, on the other hand, displays as 4 distinct gradients - green gradient is smooth but jumps in intensity in the 4 blocks. 64k colour mode uses a mapped 16bit colour value, 5 red bits, 6 green bits and 5 blue bits. I've double checked I've mapped green correctly.

I was originally thinking I have a faulty display (it was from ebay after all), but I'm having another strange problem with Green when I try 262k colour mode. In this mode, theoretically, I should send 3 bytes for the RGB values, only the bottom 6 bits are used. However, the display is only using 2 bytes - Red and Blue. If I send 3 bytes, the 3rd byte is used as the first part of the next pixel. Green never displays at all in this mode, no matter what values I send.

I've gone over the initialisation code. I've tried samples for other displays, but no luck. I've read the documenation and can't see anything that describes what I am seeing.

Any ideas?

Thanks,
Frank


Top
 Profile  
 
PostPosted: Tue Mar 30, 2010 13:02 
Offline

Joined: Thu Apr 16, 2009 5:37
Posts: 34
Location: Pakistan
ftkalcevic wrote:
I got a cheap 320x240 RGB TFT with the SSD1289 chipset on ebay and I'm having some problems. The Green isn't working as I expect.

If I run the display in 64k colour mode, I can get a smooth Red and Blue gradient. Green, on the other hand, displays as 4 distinct gradients - green gradient is smooth but jumps in .....

Any ideas?

Thanks,
Frank


Hi ,,, I have been using the SSD1289 based 3.2" TFTs with 16-bit 8080 i/f but never have been problem ,,

Looks like you are using 8-bit interface !!! because I've been facing the same RGB issue with other TFT with 8-bit 8080 IF ...

By the ways ,,,, see my great hacks of Nokia color TFTs on Sparkfun ,,

regards

maan


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group